Thursday, December 17, 2009

Unprotect Excel Worksheet

How to unprotect Excel worksheet?
Protect worksheet is secure for your Microsoft Excel data sheet. Nobody can't edit cell without knowing the password. If you forgot your own password, how to do it?
Simply way to solve it. Not matter what your original password is.
1. Download link file. That is hidden workbook.

2.Open Microsoft Excel file and activate the workbook that you want to unlock.
3.Run downloaded excel file and Click Remove Passwords button.
(If you don't see this button, go to View Menu, Toolbar, AllInternalPasswords_Bar)
It will take some times depends on how many different passwords.

P.S I really don't understand software coding. If you are interesting about and wanna see coding, go to below link.
http://www.office-it.org/excel-how-to-unprotect-worksheet-without-password/

Thursday, December 03, 2009

NTP Server on Cisco Router (part II)

Earlier post I wrote about NTP server with 1 router.

This time let configure with more than 1 router within Intranet network.
Internet <--->HQ<---->Client1
<---->Client2
1st, configure on HQ router.
configure for access-list that only have to access ntp service
(config)#access-list 77 remark AllowNTPquery
(config)#access-list 77 permit 10.101.255.0 0.0.0.255 <--10.101.255.0/24 network only (config)#access-list 77 permit
203.127.86.243

(config)#ntp access-group peer 77 <--neighbor router must match by access-list 77 (config)#ntp access-group serve-only 77
<--only access-list 77 can access
(config)#ntp server 203.127.86.243
(config)#ntp source FastEthernet0/1 <--Wan Interface or that port synchronize ntp service On Client1 Router configuration,
(config)#ntp access-group peer 77
(config)#ntp server 10.101.255.1 source FastEthernet0/0 <--10.101.255.1 is HQ's Router ip address, fa0/0 must be able to access to HQ's Router ip

Note: you can find out free public NTP server from below link
http://tf.nist.gov/tf-cgi/servers.cgi#

On Client2 Router, I will configure with sntp
(config)#sntp server 10.101.255.1 version 3

with #debug ntp sync command, you can see ntp sync to which server
for disable debug, #u all (or) #no debug ntp sync

You can verify ntp synchronize by these commands
#show ntp status
Clock is synchronized, stratum 3, reference is .....
#show ntp associations
address ref clock st when poll reach delay offset disp
~
203.127.86.243 192.36.143.150 2 10929 64 0 13.6 -0.14 16000

Verify for sntp command is
#show sntp
10.101.255.1 2 3 00:00:37 Synced


Wednesday, December 02, 2009

Gateway Loadbalancing Protocol (GLBP) with GRE Tunnel over RIP routing protocol


First, Let explain about network diagram, HQ has two internet connections. Each Branches has one internet connection. HQ is using GLBP loadbalancing protocol. All Branches and HQ are running by RIP protocol over GRE Tunnel interface.

HQ1 Router--> 1st, set the ip address for LAN and WAN

interface FastEthernet0/0
description ** WAN interface **
bandwidth 10000
ip address 172.16.97.218 255.255.255.252
speed 100
full-duplex

interface FastEthernet0/1
description ** LAN Segment **
ip address 10.100.32.97 255.255.252.0
duplex auto
speed auto

2nd-->Create site to site GRE Tunnel for Branch 1 & 2

interface Tunnel101
description ** (GRE for Branch1) **
bandwidth 512
ip address 10.101.255.1 255.255.255.252
ip rip advertise 10
tunnel source 172.16.97.218
tunnel destination 10.232.12.74
!
interface Tunnel102
description ** (GRE for Branch 2) **
bandwidth 512
ip address 10.101.255.9 255.255.255.252
ip rip advertise 10
tunnel source 172.16.97.218
tunnel destination 10.232.12.50

3rd--> Static Route for Branches

ip route 10.232.12.72 255.255.255.252 172.16.97.217 name branch1
ip route 10.232.12.50 255.255.255.252 172.16.97.217 name branch2

4th--> Create RIP

router rip
version 2
timers basic 10 60 60 80
passive-interface FastEthernet0/0
passive-interface FastEthernet0/1
network 10.0.0.0
no auto-summary

5th--> Create GLBP

From router config mode:
track 1 interface fastethernet 0/0 ip routing

From LAN interface mode:

glbp 5 ip 10.100.32.95
glbp 5 preempt
glbp 5 weighting 110 lower 95 upper 105
glbp 5 weighting track 1 decrement 20

Do the same steps in HQ2 Router
HQ2 Router-->

track 1 interface fastethernet 0/0 ip routing

interface FastEthernet0/0
description ** WAN interface **
bandwidth 10000
ip address 172.17.97.218 255.255.255.252
speed 100
full-duplex

interface FastEthernet0/1
description ** LAN Segment **
ip address 10.100.32.98 255.255.252.0
duplex auto
speed auto
glbp 5 ip 10.100.32.95
glbp 5 preempt
glbp 5 weighting 110 lower 95 upper 105
glbp 5 weighting track 1 decrement 20

interface Tunnel201
description ** (GRE for Branch1) **
bandwidth 512
ip address 10.101.251.1 255.255.255.252
ip rip advertise 10
tunnel source 172.17.97.218
tunnel destination 10.232.12.74
!
interface Tunnel202
description ** (GRE for Branch 2) **
bandwidth 512
ip address 10.101.251.9 255.255.255.252
ip rip advertise 10
tunnel source 172.17.97.218
tunnel destination 10.232.12.50

router rip
version 2
timers basic 10 60 60 80
passive-interface FastEthernet0/0
passive-interface FastEthernet0/1
network 10.0.0.0
no auto-summary

ip route 10.232.12.72 255.255.255.252 172.17.97.217 name branch1
ip route 10.232.12.50 255.255.255.252 172.17.97.217 name branch2

Branch1 Router-->1st, set the ip addresses for LAN and WAN
(in this example atm0.1 is using for WAN interface)

interface ATM0
no ip address
no ip route-cache cef
no ip route-cache
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
description ** (ATM/ADSL Wan Interface) **
ip address 10.232.12.74 255.255.255.252
no ip route-cache
pvc 8/35
protocol ip 10.232.12.73

interface Ethernet0
description Connecting to internal Lan
ip address 10.101.16.1 255.255.255.224
ip rip advertise 10
ip policy route-map clear-df
hold-queue 100 out

access-list 101 permit tcp 10.101.0.0 0.0.255.255 any

route-map clear-df permit 10
match ip address 101
set ip df 0

Why we add route-map statement? see ref:
http://www.cisco.com/en/US/tech/tk827/tk369/technologies_tech_note09186a0080093f1f.shtml

interface Tunnel101
description ** (GRE to HQ1) **
bandwidth 512
ip address
10.101.255.2 255.255.255.252
ip rip advertise 10
ip tcp adjust-mss 1436
tunnel source ATM0.1
tunnel destination 172.16.97.218
!
interface Tunnel201
description ** (GRE to HQ2) **
bandwidth 512
ip address
10.101.251.2 255.255.255.252
ip rip advertise 10
ip tcp adjust-mss 1436
tunnel source ATM0.1
tunnel destination 172.17.97.218

router rip
version 2
timers basic 10 60 60 80
network 10.0.0.0
no auto-summary
!
ip classless
ip route 172.16.97.216 255.255.255.252 ATM0.1
ip route 172.17.97.216 255.255.255.252 ATM0.1


Do the same steps for Branch2 Router;

interface ATM0
no ip address
no ip route-cache cef
no ip route-cache
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
description ** (ATM/ADSL Wan Interface) **
ip address 10.232.12.50 255.255.255.252
no ip route-cache
pvc 8/35
protocol ip 10.232.12.49

interface Ethernet0
description Connecting to internal Lan
ip address 10.101.17.1 255.255.255.224
ip rip advertise 10
ip policy route-map clear-df
hold-queue 100 out

access-list 101 permit tcp 10.101.0.0 0.0.255.255 any

route-map clear-df permit 10
match ip address 101
set ip df 0

Why we add route-map statement? see ref:
http://www.cisco.com/en/US/tech/tk827/tk369/technologies_tech_note09186a0080093f1f.shtml

interface Tunnel102
description ** (GRE to HQ1) **
bandwidth 512
ip address 10.101.255.2 255.255.255.252
ip rip advertise 10
ip tcp adjust-mss 1436
tunnel source ATM0.1
tunnel destination 172.16.97.218
!
interface Tunnel202
description ** (GRE to HQ2) **
bandwidth 512
ip address
10.101.251.2 255.255.255.252
ip rip advertise 10
ip tcp adjust-mss 1436
tunnel source ATM0.1
tunnel destination 172.17.97.218

router rip
version 2
timers basic 10 60 60 80
network 10.0.0.0
no auto-summary
!
ip classless
ip route 172.16.97.216 255.255.255.252 ATM0.1
ip route 172.17.97.216 255.255.255.252 ATM0.1


Thursday, November 12, 2009

NTP Server on Cisco Router

To show the time, clock on cisco router, use the following command
#show clock
00:01:10.415 UTC Thu Nov 12 2009
To set the time zone, use this command on enable mode
#clock timezone SGT 8 <--this example, set the singapore time zone GMT +8

To set the clock, by below command
#clock set 10:10:10 Nov 13 2009 <--format is (hh:mm:ss Month Date Year)

Note that: show clock command is showing software clock. You wanna see hardware clock type show calendar in enable mode
#show calendar

Let start about NTP protocol:
How is important TIME? Briefly says; To ensure that all network devices share a common time reference, e.g when you check the log file, call detail records for billing<--(voip), time should be same within all devices.
To synchronize the cisco router's clock with network time protocol (NTP) server, configure as below. From router config mode

(config)#ntp source ATM0.1 <-- this example I used atm0.1 is wan interface ip

(config)#ntp server sg.pool.ntp.org <--(you can find out more publc ntp server on
www.pool.ntp.org website) if you enable dns on router, dns will translate with ip address. otherwise you should add ip address manually.NTP will synchronize to ntp server periodically.

You will be noticed that ntp clock-period xxxxxx will show
in your running-config.
You don't need to configure ntp clock-period command.

As I mention earlier about hardware clock, you also want to update your hardware clock by ntp.
Do it below
(config)#ntp update-calendar





Monday, October 12, 2009

How to backup Microsoft Outlook Regularly

Backup Microsoft Outlook Regularly

Backups are an integral part of data security and integrity plans. A harddisk crash or any other incident that would remove or damage data could result in server data loss if no backup would be available that could be used to restore the system to its previous state.

Emails are nowadays one of the most important means of communication. They do not only contain personal or business detail but also about purchases, signups and other relevant information that are important to users.

Making sure that emails backup regularly ensures that it is always possible to restore them if data loss should occur.

Personal Folders Backup is an add-in for email clients Microsoft Outlook 2007, 2003, 2002. (http://www.brothersoft.com/personal-folders-backup-208123.html#)
It can be downloaded freely from the official Microsoft website also.

The installation will add the add-in the Microsoft Outlook installation. It will add a Backup entry to the file menu in Microsoft Outlook which can be used to save or open backups and to configure the backup process.

A click on the Backup link in the File menu will open the Outlook Personal Folders Backup menu.

A click on the Save Backup will schedule a backup during the next shutdown process of Microsoft Outlook using the default values of the backup program.

Outlook Personal Folders Backup will therefore backup all information of an Outlook account including the important emails, contacts of an address book and appointments in the calendar.

A click on options will open configuration options. It is possible to select the personal folders that should be backed up and the file location where the backups should be stored. It is furthermore possible to configure a reminder that will remind the user after x days about the backups.

Creating backups makes only sense if there is a way to restore the data that has been backed up. Outlook Personal Folders Backup comes with the means to restore the previously backed up data.

A click on the Open Backup button will open a previously created backup in Microsoft Outlook. Opening the Personal Folders backup will for instance add the same structure containing all mails and other information in the list of configured mail folders. It is then possible to drag and drop mails and other information from the backup mail folders to the original ones thus restoring any information that gets transferred.

The backup software will display information about the last backup once at least one backup has been created using the Outlook add-in. This can be helpful to determine if a new backup should be created.

Thursday, September 10, 2009

BGP Case Study Tutorials

When I'm googling about BGP guides, I found that these pages are very useful and understand very well for configuring router. I just share for BGP Case Study Tutorials pages.

http://netcenter.cumt.edu.cn/network/wlzs/bgp/BGP-Case-Studies.pdf

Friday, May 08, 2009

Cisco 877 Router Configuration by SDM Express

For Cisco 877 Router installation is very easy with SDMExpress mode. (I don't mention with Cisco SDM and CLI).
1. Assign the Username and Password for Router
2. Assign the Lan IP address (e.g: ip address-192.168.1.254, subnet mask-255.255.255.0)
3. Assign the Wan Interface
  • Encapsulation : PPPoA(AAL5SNAP)
  • VPI: 0, VCI:100
  • Address type: Ip Negotiated
  • Authentication Type : PAP
Fill the UserName and Password for Dynamic Link
4. If you want to Enable DHCP, just click enable and assign IP address.
5. Enable NAT
6. Enable Default Route by Dialer0 interface
7. Apply Changes.

Pls take note: If not working Encapsulation type PPPoA and Authentication PAP, try with other PPPoE and Authentication Type CHAP.

For more detail: find Attachment file. http://www.mediafire.com/?lyumzjxdnjz

Tuesday, April 21, 2009

Cisco IOS Recovery

Initially, you need tftp server (you can refer the link http://www.dslreports.com/faq/9816). Keep in mind that the router and the tftp sever needs to be same subnet and have the same default gateway.
Type below command from ROMMON prompt,

rommon>IP_ADDRESS=10.0.0.1

rommon>IP_SUBNET_MASK=255.255.255.0
rommon>DEFAULT_GATEWAY=10.0.0.1
rommon>TFTP_SERVER=10.0.0.25
rommon>TFTP_FILE=c1700-k9o3sy7-mz.124-5a.bin

You can check that everything is set up correctly by entering set on its own.
Once you are happy then enter tftpdnld at the ROMMON prompt and your IOS image will be installed from your tftp server.

(note: This will erase the flash so any other files stored there will be lost.)
(note: With ROMMON mode case (uppercase or lowercase) is important so make sure you enter command and variables.

References:
http://www.dslreports.com/faq/13824

Sunday, March 08, 2009

MS DHCP Server with Multiple VLans on Cisco Router

MS DHCP Server in a VLAN Environment
1.use multiscpoe option in MS DHCP Server.
2.Create scopes on the dhcp server with address pools like "192.168.1.0/24 ,192.168.2.0/24,....for each vlan.
3.create vlan interfaces on the router for each vlan, assign ip addresses and masks to the interfaces according to your DHCP scopes.
4.configre "ip healper address" on the router/L3 switch.
5. you are done.

Configuring DHCP/BootP relay agent on Cisco Router

Configuring a Router to forward DHCP/BootP is very simple. Configure an IP helper-address pointing to the DHCP/BootP Server, or pointing to the subnet broadcast address of the network the server is on.

To forward the BootP/DHCP request from the client to the DHCP server, the ip helper-address interface command is used. The IP helper-address can be configured to forward any UDP broadcast based on UDP port number.

For Example:
interface Ethernet0
ip address 192.168.2.1 255.255.255.0
no ip directed-broadcast
!
interface Ethernet1
ip address 192.168.1.1 255.255.255.0
ip helper-address 192.168.2.2
ip helper-address 192.168.2.3

!--- IP helper-address pointing to DHCP server
===============================================

Reference from cisco and techrepublic website.

Cisco Router Reset Password

To reset the password. Please to do so following procedure

Attach a terminal or PC with terminal emulation to the console port of the router.

Use these terminal settings:

9600 baud rate

No parity

8 data bits

1 stop bit

No flow control

(Note: If you can't enter to recovery mode, take out the WIC if you inserted in Router.)
Press Break on the terminal keyboard within 60 seconds of power up in order to put the router into ROMMON.

If the break sequence does not work, refer to Standard Break Key Sequence Combinations During Password Recovery for other key combinations.

Type confreg 0×2142 at the rommon 1> prompt in order to boot from Flash.

This step bypasses the startup configuration where the passwords are stored.

Type reset at the rommon 2> prompt.

The router reboots, but ignores the saved configuration.

Type no after each setup question, or press Ctrl-C in order to skip the initial setup procedure.

Type enable at the Router> prompt.

You are in enable mode and should see the Router# prompt.

Type configure memory or copy startup-config running-config in order to copy the nonvolatile RAM (NVRAM) into memory.

Important: Do not type copy running-config startup-config or write. These commands erase your startup configuration.

Type show running-config.

The show running-config command shows the configuration of the router. In this configuration, the shutdown command appears under all interfaces, which indicates all interfaces are currently shut down. In addition, the passwords (enable password, enable secret, vty, console passwords) are in either an encrypted or unencrypted format. You can reuse unencrypted passwords. You must change encrypted passwords to a new password.

Type configure terminal.

The hostname(config)# prompt appears.

Type enable secret <password> in order to change the enable secret password. For example:

hostname(config)#enable secret cisco

Issue the no shutdown command on every interface that you use.

If you issue a show ip interface brief command, every interface that you want to use should display up up.

Type config-register . Where configuration_register_setting is either the value you recorded in step 2 or 0×2102 . For example:

hostname(config)#config-register 0×2102

Press Ctrl-z or end in order to leave the configuration mode.

The hostname# prompt appears.

Type write memory or copy running-config startup-config in order to commit the changes.


Hope to help

Reference by http://blog.yucas.info/2008/03/11/cisco-1841-password-recovery/